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Viewing the Start Here Pages, Troubleshooting Information,
and Release Notes

This section contains directions on accessing information you may want or
need before you begin installation:

• (Required for IRIX Operating System and Overlay Releases Only) Follow the
instructions in “How to View the Start Here Pages” before you upgrade
your IRIX operating system.

• (Optional) See “How to Access Inst Troubleshooting” if you want to print
out troubleshooting documentation for Inst, the program used for
installing an operating system.

• (Optional) See “How to View the Release Notes Before Installation” to find
out how to view product Release Notes. Product Release Notes typically
include known bugs and workarounds, a description of changes
particular to the product release, and compatibility information.

How to View the Start Here Pages

Reviewing the Start Here pages is the first step in upgrading an IRIX operating
system:

Note: Start Here is not applicable for single application
installations/upgrades.
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1. Insert the CD that includes “Installation Tools” in the title into the
CDROM drive.

2. Open a Web browser and go to

file:/CDROM/WhatsNew/yourSystem.html

3. Click the Start Here link.

The Start Here pages include key information such as minimum
requirements, major (pre/post-installation) caveats for this release, CD
descriptions to help you determine which CDs you need to use, and an
overview of the new software included in the release.

Note: After you complete the upgrade, you can access the Start Here pages
by double-clicking the Welcome_to_SGI icon on your desktop.

How to Access Inst Troubleshooting

You may want to access (or print out) the Troubleshooting section of IRIX
Admin: Software Installation and Licensing. To access it:

1. Log in.

2. Insert the IRIX 6.5 Base Documentation CD into the CD-ROM drive.

3. Open a shell: From the Toolchest, choose Desktop > Unix Shell.
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4. Go to the CDROM directory.

The default CD-ROM directory location is /CDROM, so at the shell
prompt, enter cd /CDROM

5. Enter ./CDinsight to launch the IRIS InSight book viewer.

6. Click the SGI Admin tab and double-click the IRIX Admin: Software
Installation and Licensing book icon.

The Troubleshooting section is the last section of the book.

Note: You can also find this book at the Technical Publications Library
Web site (http://techpubs.sgi.com).

How to View the Release Notes Before Installation

To view product-specific Release Notes, follow steps 1 through 4 above, then
enter ./CDgrelnotes to launch the Release Notes viewer.
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Installing an Intermediate (Overlay) Release

Use the instructions in this section to do either of the following:

• Install an intermediate release (also known as overlay, feature, or
maintenance release).

• Or, if you have not yet upgraded to the corresponding base operating
system, install both the overlay (for example, 6.5.x) and the base
operating system (for example, 6.5) at the same time.

The installation program used in these instructions is called Inst. Inst has
online help. To see the list of Inst help topics, enter the command help help
at the Inst prompt. For more details on using Inst, see the online book IRIX
Admin: Software Installation and Licensing.

Special Instructions for Server Installations: To Install an overlay on a server
instead of a workstation, replace steps 3, 4, and 5 below with steps 3, 4, 5, 6,
and 7 under “Installing IRIX on a Server” on page 19.

Preparation

1. Use the Start Here pages to print or make a note of:

• Minimum requirements and any major caveats for these releases. Very

Important—Some information may affect your installation process!
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• If you also need to install the base operating system (OS), refer to the
“CD Descriptions” section to determine which of the OS CDs you
need to use during the installation.

See “How to View the Start Here Pages” on page 2.

Preinstallation

2. Insert the “Installation Tools and Overlays” CD (labeled 1 of 2) in the
CD-ROM drive—do not use the Installation Tools CD that goes with the
base IRIX operating system package (for example, do not use the IRIX 6.5
Installation Tools CD).

Note: If you are using a distribution directory instead of a CD, skip this
step—you will load the Installation Tools directory in another step.

3. Bring up the system maintenance menu:

■ From the Toolchest, choose System > System Shutdown.

■ When you see the message Okay to power off, press the Esc key.
As soon as you see the message Starting up the system, press
the Esc key again (or click the Stop for Maintenance button).

A menu screen should appear now. (If it doesn’t, you probably did not
press the Esc key soon enough; begin step 3 again.)

4. Click the Install System Software icon on the menu screen.
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5. Specify the location of the new software to install:

• If the location is a CD in a drive connected to your system, click the
Local CDROM icon, click the Install button, then click Continue in the
dialog box that appears. (If you are installing onto a clean disk, see the
note below.)

• If the location is a CD drive or a directory on a remote system, click
the Remote Directory icon. You are prompted for the remote hostname.
Enter the name of the remote system that contains the distribution.
Next, you are prompted to enter the pathname of the distribution
source on the remote system—for example, if the source is a CD, enter
/CDROM/dist. Click the Install button.  If a network error message
appears, refer to 8“Troubleshooting Remote Installations” on page 28.

Note: If you are installing on a clean disk, a message appears that
includes make new filesystem, and ends with [yes/no/sh/help].
Enter yes to make the new filesystem. You are asked to confirm this—
enter yes. You are asked to enter a block size. If you don’t know what to
enter, enter 4096.

6. Load the CDs (or directories) so that Inst can read the product lists before
the actual installation—refer to “Loading Multiple CDs During IRIX
Installations” on page 24, then return to step 7.
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7. Make your installation selections. To install all upgrades and related
(prerequisite) products:

Inst> keep *

Inst> install standard

Inst> install prereqs

Inst> keep incompleteoverlays

If you are installing onto a clean disk, these commands select and install
all standard software, plus necessary prerequisite software and patches.

Note: You may see a message saying there were no matches for
prereqs or for standard—this does not indicate an error.

If you are familiar with using the program Inst, you can also choose to
install new products now. Otherwise, proceed to step 8.

Tip: For information on viewing or altering the products that are marked
for installation, see step 10 under “Installing IRIX on a Server” on page 19.

Installation

8. Enter go at the prompt to begin the installation.

If there are no “Conflicts” messages, proceed to step 9.

If your installation selections have generated conflicts, Inst asks you if
you want to address them now. Enter 1 for “Address these conflicts now.”
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To resolve conflicts, enter conflicts choice choice. For example, enter
conflicts 1b 2a to indicate that for conflict 1 you choose choice b
and for conflict 2 you choose choice a. See also “Tips for Resolving
Installation Conflicts” on page 27.

Enter go again when all conflicts are resolved. A preinstallation check
begins.

9. If you see a message similar to

Please insert the “<CD title>” CD
Type Ctrl-C to interrupt

insert the specified CD in the CD drive.

In some cases, the message that indicates which CD to insert may include
Error/Interrupt Menu—this does not signify a problem. Insert the
requested CD, return to the Inst prompt, and enter retry.

It may take several minutes for each CD to install. Eventually a new
message will prompt you to insert the next CD or indicate that the
installation is complete.
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Postinstallation

10. When Inst indicates that the installation is finished, enter quit.
Postinstallation processes begin. When they are complete, you see:

Ready to restart the system. Restart?

Enter y to restart the system, which completes the installation process.

Now that the IRIX operating system is upgraded, you can log in and use
Software Manager to select and install some of the new products that were
included with your IRIX software package. See “Installing Applications on a
Workstation” on page 15 or “Installing Applications From a Remote CD
Drive” on page 17.

Installing IRIX on a Workstation

The installation program used in these instructions is called Inst. Inst has an
extensive online help feature. To see the list of topics on which help is
available, enter the command help help at the Inst prompt. For more details
on using Inst, see the online book IRIX Admin: Software Installation and
Licensing.

Note: You can install an intermediate (overlay) release and the base IRIX
operating system at the same time. To so, follow the instructions in “Installing
an Intermediate (Overlay) Release” on page 5.
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Follow these steps in order. They are divided into categories (Preparation,
Preinstallation, Installation, Postinstallation) to clarify the different stages of
upgrading.

Preparation

1. Use the Start Here pages to print or make a note of:

• Minimum requirements and any major (pre/post-installation) caveats
for this release. Very Important—Some caveats may affect your
installation process!

• The “CD Descriptions” section, to determine which CDs you need to
use during the installation.

See “How to View the Start Here Pages” on page 2.

Preinstallation

2. Insert the Installation Tools CD in the CD-ROM drive. (It is important that
you load this CD first.)

Note: If you are using a distribution directory instead of a CD, skip this
step—you will load the Installation Tools directory in another step.

3. Bring up the system maintenance menu:

■ From the Toolchest, choose System > System Shutdown.
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■ When you see the message Okay to power off, press the Esc key.
As soon as you see the message Starting up the system, press
the Esc key again (or click the Stop for Maintenance button).

A menu screen should appear now. (If it doesn’t, you probably did not
press the Esc key soon enough; begin step 3 again.)

4. Click the Install System Software icon on the menu screen.

5. Specify the location of the new software to install:

• If the location is a CD in a drive connected to your system, click the
Local CDROM icon, click the Install button, then click Continue in the
dialog box that appears. (If you are installing onto a clean disk, see the
“installing on a clean disk” bullet below.)

• If the location is a CD drive or a directory on a remote system, click
the Remote Directory icon. You are prompted for the remote hostname.
Enter the name of the remote system that contains the distribution.
Next, you are prompted to enter the pathname of the distribution
source on the remote system—for example, if the source is a CD, enter
/CDROM/dist. Click the Install button.  If a network error message
appears, refer to “Troubleshooting Remote Installations” on page 28.

• If you are installing on a clean disk, a message appears that includes
make new filesystem, and ends with [yes/no/sh/help]. Enter
yes to make the new filesystem. You are asked to confirm this—enter
yes. You are asked to enter a block size. If you don’t know what to
enter, enter 4096.
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6. Load the CDs (or directories) so that Inst can read the product lists before
the actual installation—refer to “Loading Multiple CDs During IRIX
Installations” on page 24, then return to step 7.

7. Make your installation selections. To install all upgrades and related
(prerequisite) products:

Inst> keep *

Inst> install standard

Inst> install prereqs

You may see a message saying no matches for prereqs or for
standard—this does not indicate an error.

Note: If you are installing onto a clean disk, these commands select and
install all standard software, plus necessary prerequisite software and
patches.

If you are familiar with using the program Inst, you can also choose to
install new products now. Otherwise, proceed to the next step.

Tip: For information on viewing or altering the products that are marked
for installation, see step 10 under “Installing IRIX on a Server” on page 19.

Installation

8. Enter go at the prompt to begin the installation.

If there is no message about conflicts, proceed to step 9.
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If your installation selections have generated conflicts, Inst asks you if
you want to address them now. Enter 1 for “Address these conflicts now.”

To resolve conflicts, enter conflicts choice choice. For example, enter
conflicts 1b 2a to indicate that for conflict 1 you choose choice b
and for conflict 2 you choose choice a.  See also “Tips for Resolving
Installation Conflicts” on page 27.

Enter go again when all conflicts are resolved. A preinstallation check
begins.

9. When you see a message similar to

Please insert the “<CD title>” CD
Type Ctrl-C to interrupt

insert the specified CD in the CD drive.

In some cases, the message that indicates which CD to insert may be titled
Error/Interrupt Menu—this does not signify a problem. Insert the
requested CD, return to the Inst prompt, and enter retry.

It may take several minutes for each CD to install. Eventually a new
message will prompt you to insert the next CD or indicate that the
installation is complete.
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Postinstallation

10. When Inst indicates that the installation is complete, enter quit.
Postinstallation processes begin. When they are finished, you see:

Ready to restart the system. Restart?

Enter y to restart the system, which completes the installation process.

If you have not yet done so, check the “After You Install” section in the Start
Here pages to make sure you are aware of any major postinstallation caveats
(as instructed in step 1).

Now that the IRIX operating system is upgraded, you can log in and use
Software Manager to select and install some of the new products that were
included with your IRIX software package. See “Installing Applications on a
Workstation” on page 15 or “Installing Applications From a Remote CD
Drive” on page 17.

Installing Applications on a Workstation

To install applications from a CD-ROM drive that is connected to your system,
follow the instructions in the following section, “Installing Applications From
a Local CD Drive.”
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To install applications from a CD-ROM drive that is connected to another
system on your network, follow the instructions in “Installing Applications
From a Remote CD Drive” on page 17.

For more details about software installation, including how to customize your
installation and troubleshoot, refer to the Software Manager Help menu.

Note: Installing applications is different from upgrading to a new version of
IRIX. If you are upgrading your IRIX operating system, be sure to follow the
appropriate instructions (refer to the table of contents on page 1). After you
upgrade IRIX, you can log in and use Software Manager to select and install
some of the new software products that were included with your IRIX
package. To do so, use the directions in this section.

Installing Applications From a Local CD Drive

1. Insert the CD in the CD drive.

2. Open Software Manager by double-clicking the CDROM icon on your
desktop.
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3. To install all upgrades and new products, proceed to step 4; otherwise,
click Customize Installation to select specific products:

■ After the Software Inventory is displayed, click to select the products
you want to install.

■ If a product has Release Notes, the product name turns blue when you
click it. Click again to display Release Notes, or choose Selected >
Release Notes.

4. Click the Start button.

5. When the installation is complete, choose File > Quit.

6. Eject the CD from the drive.

Select the CDROM icon, hold down the right mouse button, and choose
Eject.

Installing Applications From a Remote CD Drive

1. Insert the CD in the remote CD drive.

2. From the Toolchest on your system, choose System > Software Manager.

3. In the Available Software field, enter the remote system’s name and the
distribution directory path.  For example:

mars:/CDROM/dist

Note: If a network error message appears, refer to “Troubleshooting
Remote Installations” on page 28.
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4. Click the Lookup button.

5. To install all upgrades and new products, proceed to step 6; otherwise,
click Customize Installation to select specific products:

■ After the Software Inventory is displayed, click to select the products
you want to install.

■ If the product has release notes, the product name turns blue when
you click on it. Click again to display release notes, or choose Selected
> Release Notes.

6. Click the Start button.

7. When the installation is complete, choose File > Quit.

8. Eject the CD from the drive.

Select the CDROM icon on the remote system’s desktop, hold down the
right mouse button, and choose Eject.

Installing IRIX or Applications on a Server

The installation program used in these instructions is called Inst. Inst has an
extensive online help feature. To see the list of topics on which help is
available, enter the command help help at the Inst prompt. For more details
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on using Inst, see the online book IRIX Admin: Software Installation and
Licensing.

Installing Applications on a Server

If you are installing application software (not upgrading the IRIX operating
system), it is not necessary to restart the system and perform the installation
from the miniroot. Instead:

1. Open a shell and enter su to become superuser.

2. Enter inst.

3. Enter from followed by the distribution path—for example, if you are
installing from a local CD-ROM drive, enter from /CDROM/dist

4. Proceed to step 9 of “Installing IRIX on a Server,” below.

Installing IRIX on a Server

Note: You can install an intermediate (overlay) release and the base IRIX
operating system at the same time. To so, follow the instructions in “Installing
an Intermediate (Overlay) Release” on page 5.

Follow these steps in order. They are divided into categories (Preparation,
Preinstallation, Installation, Postinstallation) to clarify the different stages of
the installation.



20

Preparation

1. Use the Start Here pages to print or make a note of:

• Minimum requirements and any major (pre/post-installation) caveats
for this release. Very Important—Some caveats may affect your
installation process!

• The “CD Descriptions” section, in order to determine which CDs you
need to use during the installation.

See “How to View the Start Here Pages” on page 2.

Preinstallation

2. Insert the Installation Tools CD in the CD drive. (It is important that you
load this CD first.)

Note: If you are using a distribution directory instead of a CD, skip this
step—you will load the Installation Tools directory in another step.

3. Become superuser and shut down the system:

% su

# shutdown

When you see the message Do you want to continue with the
shutdown (yes/no) [no], enter yes.

4. If prompted, choose Restart, then press Esc to Stop for Maintenance.
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5. You are given a list of choices at the system maintenance menu. Enter 2
for Install System Software.

6. Specify the distribution source:

• If the source is a CD drive connected to the workstation, enter the
number for the local CD-ROM selection. (You may have to press
Enter twice.)

• If the source is on another system:

– Enter the number for the remote directory selection.

– When prompted, enter the name of the remote system that contains
the distribution.

– Enter the pathname of the distribution source on the remote
system—for example, if the source is a CD, enter /CDROM/dist

7. Press Enter to start the miniroot and Inst.

Rows of dots and various messages appear. Wait for the Inst prompt.

Note: If a network error message appears, refer to “Troubleshooting
Remote Installations” on page 28.

8. Load the CDs (or directories) so that Inst can read the product lists before
the actual installation—refer to “Loading Multiple CDs During IRIX
Installations” on page 24, then return to step 9.
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9. Make your installation selections. To install all upgrades and related
(prerequisite) products:

Inst> keep *

Inst> install standard

Inst> install prereqs

You may see a message saying there were “no matches for prereqs” or for
“standard”—this does not indicate an error.

Note: If you are installing onto a clean disk, these commands select and
install all standard software, plus necessary prerequisite software and
patches.

10. (Optional) If you want to view or alter the products that are marked for
installation, enter list:
Inst> list

Each product is marked:

– N indicates that the product is new.

– [d] indicates that the product is installed by default unless
otherwise instructed.

–  i indicates that the product will be installed.

–  r indicates that the product will be removed.

– [r] indicates that the product is required.
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You may change the installation status of any product in the distribution
listed. Tips for making selections:

• To select software that is not already selected, use the install command.
For example: install ViewKit_dev.sw.lib

• If there is software you do not wish to install, use the keep command.
For example: keep ViewKit_dev.sw.lib

11. Enter conflicts to see if your installation selections have generated any
conflicts. If there are no conflicts, proceed to step 12.

To resolve conflicts, enter conflicts choice choice. For example, enter
conflicts 1b 2a to indicate that for conflict 1 you choose choice b
and for conflict 2 you choose choice a.

See also “Tips for Resolving Installation Conflicts” on page 27.

Installation

12. Enter go.

13. When you see a message similar to

Please insert the “<CD title>” CD
Type Ctrl-C to interrupt

insert the specified CD in the CD drive.

In some cases, the message that indicates which CD to insert may be titled
Error/Interrupt Menu—this does not signify a problem. Insert the
requested CD and return to the Inst prompt to enter retry.
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It may take several minutes for each CD to install. Eventually a new
message will prompt you to insert the next CD or indicate that the
installation is complete.

Postinstallation

14. When Inst indicates that the installation is complete, enter quit.
Postinstallation processes begin. When they are finished, you see:

Ready to restart the system. Restart?

Enter y to restart the system, which completes the installation process.

(Operating System Installations Only) If you have not yet done so, check the
“After You Install” section in the Start Here pages to make sure you are aware
of any major postinstallation caveats (as instructed in step 1).

Loading Multiple CDs During IRIX Installations

This section is a subset of the IRIX (and intermediate release) installation
instructions. Follow the instructions below to load the CDs (or distribution
directories) so that Inst can read the product lists. You will be prompted to
load the CDs again during the actual installation, but Inst needs to read all the
product lists first in order to prevent many product conflicts during
installation.
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Note: To determine which CDs you need to install from, refer to the CD
Descriptions section of the Start Here pages.

1. At the Inst prompt, use the open command to tell Inst to read the
Installation Tools CD (or distribution directory):

If the CD is local, enter open /CDROM/dist

If the CD is in a remote drive, open the CD distribution directory on the
remote system, for example: open mars:/CDROM/dist

If the distribution is a directory, open the pathname for the Installation Tools
CD, for example:
open mars:/6.5/cd1

Note: A README may appear that contains information about the release
and a description of an optional script that checks for old kernel files and
large files you may no longer need and, with your approval, removes
them. Follow the script prompts if you choose to run the script.

2. If you see the following message, enter 1 or 2. (If you are not sure which
stream to choose, refer to the Start Here pages for clarification.)
1. Place me on the maintenance stream.

2. Place me on the feature stream.

3. Cancel

Please enter a choice [1]:
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3. When you see a message similar to Install software
from:[/CDROM/dist], replace the current CD or distribution directory
with the next one:

If the CD is local, eject the current CD by pressing the manual eject button
on the CD drive.

If the CD is in a remote drive, eject the current CD by selecting the CDROM
icon on the remote desktop, holding down the right mouse button, and
choosing Eject. (Alternatively, enter eject /CDROM  in a shell on the
remote system.)

If the distribution is a directory, open the next directory, for example:
open mars:/6.5/cd2

Note: If you are installing from a CD, always make sure that the prompt
indicates that the installation is from the /CDROM/dist directory. For
example, if the prompt changes to reflect the /CDROM/dist/dist6.5
directory, enter /CDROM/dist at the prompt.

4.  Press Enter to instruct Inst to read the new CD or distribution directory.

Caution:  Do not enter “done” until all the CDs or distribution directory
have been read.

5. Continue loading each CD or distribution directory.

6. When all the relevant CDs or distribution directories have been read,
enter done.
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Tips for Resolving Installation Conflicts

• If the list of conflicts is long, enter q to stop viewing the list and resolve
the conflicts currently visible on the screen. Once you’ve resolved the
visible conflicts, enter conflicts again to view the remaining conflicts.
The other option is to write down all of your choices before you enter
them.

• If a conflict gives you the option of deselecting products with “eoe” or
“Execution Environment” in the product name, do not choose to deselect
these products. The operating system needs these products in order to
function properly.

• If you deselected subsystems, conflicts may be generated by remaining
patches that go with the deselected subsystems. However, you do not
need these patches; choose not to install them.

• If you need to resolve conflicts by loading a CD, the installation selections
you already made may be altered on the CD you load. Review what is
selected on the CD and deselect or reselect as needed.
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Troubleshooting Remote Installations

When a network error message appears during a remote installation, try the
following:

• If you see an error similar to Cannot load network (0)
bootp()<system name>:/CDROM/dist, check that tftp access to the
CDROM is enabled on the remote system. Detailed instructions are in the
online Personal System Administration Guide. To find the section in the
book, search for “tftp.” You can access the book from the Toolchest
(choose Help > Online Books), or from http://techpubs.sgi.com.

• Check the network connection; make sure that cables are secure.

Installing Software Licenses

For products that require a license to run, you must activate a license for that
product on your system. You should have received a license information sheet
or label from Silicon Graphics. If you do not have this sheet/label, contact
Silicon Graphics or your local support provider.
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Silicon Graphics uses FLEXlm to license its products. The following pages
describe how FLEXlm Nodelocked and floating/concurrent licenses are
installed using License Manager. (Note that the terms “floating license” and
“concurrent license” are interchangeable.) For information on installing
Silicon Graphics software (including License Manager), refer to the section
“Installing Applications on a Workstation” on page 15 or “Installing
Applications on a Server” on page 19.

Additional licensing information can be found by visiting the Silicon Graphics
World Wide Web licensing page:

http://www.sgi.com/Products/license.html

Installing a FLEXlm Nodelocked License

To install FLEXlm Nodelocked licenses you must invoke License Manager and
install the license. If you are installing a license for XFS Volume Plexing or any
other product that must be installed in a directory other than /var/flexlm, then
refer to the release notes for license installation instructions.

To install the license, follow this procedure:

1. Choose System > License Manager from the Toolchest to open License
Manager.

2. Click the Install... button.

3. Select FLEXlm Nodelock.
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4. Click the OK button.

5. Copy all requested fields from the license information sheet or label into
the “License Manager: Install FLEXlm Nodelock License” window.

6. Click the OK button.

7. Repeat steps 2 through 6 until all licenses are installed.

8. Click the Close button on the main License Manager window.

You are finished installing the license(s). Save the license information sheet or
label; you may need it again later to reinstall your license(s).

Installing a FLEXlm Floating (Concurrent) License

Note: The information in this section should be used only by the system
administrator of the license server system. If you are an end user of client
software with a floating license that is not functioning, contact your system
administrator.

If you are installing a license for a product that must be installed in a directory
other than /var/flexlm, refer to the product’s release notes for license
installation instructions.

Floating licenses require a network license server. The subsystem
license_eoe.sw.flexlm_server must be installed on that system. Verify that it is
installed by opening a UNIX  shell and entering

showprods license_eoe.sw | grep flexlm_server | wc -w
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If the result is greater than 0 (for example, 7), the subsystem is installed; if the
result is 0, you must install license_eoe.sw.flexlm_server.

With FLEXlm, a floating license must be installed on the license server and the
license file copied to every client system. The license manager daemon, lmgrd,
should then be started on the license server. You do not need to start license
daemons on client systems

To install the license on the license server system using License Manager,
follow this procedure:

1. Choose System > License Manager from the Toolchest to open License
Manager.

2. Click the Install... button.

3. Click FLEXlm Floating.

4. Click the OK button.

5. If necessary, enter the Server Host Name in the corresponding field. (To
find the name, enter the UNIX shell command uname -n on the server.)

6. Copy all requested fields from the license information sheet into the
“License Manager-Install FLEXlm Floating License” window.

7. Click the OK button.

8. Repeat steps 2 through 7 until all licenses for the server are installed.

9. Click the Close button on the main License Manager window.
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Start the license daemon (only on the license server system):

1. Become superuser.

In a UNIX shell, enter su.

2. Enter chkconfig flexlm on

3. Stop the lmgrd daemon.

Enter /etc/init.d/flexlm stop

4. Start the lmgrd daemon.

Enter /etc/init.d/flexlm start

5. Exit the root account: enter exit

On any system you wish to access this license from, you must copy (or mount)
the license file (/var/flexlm/license_<server_name>.dat) from the server system
into the /var/flexlm/license_<server_name>.dat file (on all client systems).

You are finished installing the license. Save the license information sheet or
label; you may need it again later to reinstall this license.
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Troubleshooting FLEXlm Software Licenses

Use the methods described in this section for basic troubleshooting. See our
software licensing Web site (http://www.sgi.com/Products/license.html) for
more information.

• Enter the UNIX command

/usr/sbin/lmdiag -c /var/flexlm/license.dat

(or /usr/sbin/lmdiag -c /var/flexlm/license_serverhost.dat)

to analyze the licenses in the license files. If you see an error message that
says the HOSTID is incorrect, then follow these steps:

– For a Nodelocked license, run the UNIX command /etc/sysinfo
-s. If the result does not match the HOSTID string for that product in
the license file, this is the problem.

– For a floating license, on the server system, run the UNIX command
/etc/sysinfo -s. Compare the results with the second argument
on the SERVER line, which corresponds to the product in question. If
the two numbers are not identical, this is the problem.

Conditions that might cause the /etc/sysinfo -s results and the HOSTID to
be different include:

– the license may be for a system different from the one it is installed
on,

– the HOSTID may have been entered incorrectly,
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– or, the HOSTID on the system may have changed (replacing the
system board or I/O board can change the HOSTID).

• For trouble with a floating FLEXlm license, configure the lmgrd daemon
on the server to send its output to a log file by adding

-c /var/flexlm/license_server_name.dat -l
/var/adm/flexlm.log

to the /etc/config/lmgrd.options file, where /var/adm/flexlm.log is the log file.
(Note that -l is the lowercase letter l, not the number one.) In a UNIX
shell, enter

/etc/init.d/flexlm stop; /etc/init.d/flexlm start

Look at the log file for error messages.

If the application program (or lmstat) cannot connect to the license server,
one of several things may be wrong:

– The license server may be down, or there may be a network
problem. Verify that the client system can communicate with the
server. In a UNIX shell on the server, enter this command:

setenv LM_LICENSE_FILE /var/flexlm/license_server_name.dat

Then, enter /usr/sbin/lmstat -a to verify the vendor daemon is
running.
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In a UNIX shell on the client system, enter lmstat -a to check if the
system can contact the vendor daemon on the server. Then, from the
client system, enter the command telnet hostname portnumber, where
hostname and portnumber match the SERVER line in the license file.

– The Silicon Graphics vendor daemon may not be running. On the
server, verify that it is running by entering the UNIX command ps
-ef | grep sgifd | grep -v grep. If nothing is returned,
then the vendor daemon is not running.

– The application may not be looking at the expected license file. The
default license file for Silicon Graphics products is
/var/flexlm/license.dat. Verify the contents of /var/flexlm/licensefile.db
to see what files are being looked at. To view contents lists of all

expected license files, enter:

more /var/flexlm/licensefile.db

• If a warning message appears stating that the license expires in an
incorrect number of days, remove or comment out temporary or
evaluation license(s) in the /var/flexlm/license.dat file for this product.

• The License Password may have been entered incorrectly. Check that the
letters l and O were not typed in place of a numeral 1 (one) and 0 (zero).

• Run the date command by entering date. Make sure the date is not earlier
than the Start Date or later than the Expiration Date listed on the license
information sheet.
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For more information on troubleshooting, refer to Appendix B of the FLEXlm
End User Manual. This guide is located in the IRIS InSight Library (on the
EndUser Bookshelf), which you can find by choosing Help > Online Books
from the Toolchest.


